EXPRESS PCB TUTORIAL

Revised 1/11/2010!

This tutorial leads you through the design of a PCB using layout software from ExpressPCB,
which is freeware available at www.expresspcb.com. Before beginning you should make sure
your computer has both ExpressPCB and ExpressSCH, if not than you should download the
software. Before beginning the PCB process, you should come up with the initial design, build it
and test it on a breadboard, fix any errors, and determine specific components. It is also useful to
have datasheets and dimensions for all of the “special” components such as transistors, ICs, sensors,
actuators, etc., on hand. For this tutorial, we will use a drawer burglar alarm circuit, which had the
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There are two stages remaihing in the process to creating the circuit board. In the first stage,

you build the schematic using the ExpressPCB schematic editor. In the second stage you layout the
circuit board. It is possible to skip directly to the layout editor. However, doing the schematic first

will allow you to link the schematic into the layout editor reducing the probability of error.

Entering the Schematic into ExpressSCH

1. Open ExpressSCH to create a fresh schematic. The first time you start ExpressSCH you
will get a dialog box with a link to a quick start guide for ExpressSCH. This can be useful if
you want to get a general overview for the tool. Once you are ready to start, close the dialog
box to view the empty schematic.

! Clarification corrected/noted in PCB Step 28
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2. Click on Op-Amp-like symbol to place components. To place the resistors, select “Passive-
Resistor” in the text box in the upper right corner.
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3. Then click on the schematic for the 4 resistors (not including the photoresistor or
potentiometer) in roughly the location you want them to display. Then zoom in using the
magnifying glass tool (or the wheel on the mouse) and pan the display (using the sliding
bars) to improve your view.
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4. Now you need to give each of the resistors unique identifiers. Right click on a resistor and
choose “Set component properties.” In the Component Properties box, under “Component
ID,” select “Auto assign Part ID.” The program should assign this resistor to be R1. Set its
value 10k in the “Part Name” field and hit OK. Repeat this process to identify and label

R2 (10k), R3 (100k), and R4 (10k).
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5. Rotate R4 by right clicking on it, selecting “Rotate component” and then “Body left 90°”
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6. Now add the capacitor, potentiometer, comparator, and transistor to the circuit by first
clicking back on the component placement tool (the red op-amp symbol) and using the
component names “Passive-Capacitor polarized,” “Passive- Potentiometer,” “IC — National
- LM311 — Comparator — DIP-8,” and “Semiconductor — Transistor NPN.” Use “set
component properties” to assign all of these parts Part IDs, label them and position them
(using the arrow tool) in a logical manner.
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7. Now we need to add some components (the photoresistor and the buzzer) that don’t exist in
the library. Let’s start with the photoresistor. The easiest way to make new parts is to start
with a symbol that’s already close to what you want and modify it. Place a regular resistor
on the layout (using the placement tool with ‘Passive — Resistor’). Go to the selection tool
(the arrow), choose that resistor and go to the “Component” menu at the top and select
“Ungroup component”
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8. Using the circle shaped tool from the tool menu, draw a circle around the resistor.
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9. Select the whole object (using the arrow tool), and choose “Component” -> “Group to make

component”
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10. In the component properties box that appears, assign the photoresistor a unique part ID, such
as “PR1”.
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11. For future use, save this as a custom component by selecting “Component” -> “Save custom
component” and then in the dialog box that appears give the component a name such as
“photoresistor.” (If someone else has already completed the tutorial on this computer, the
part may already exist, in that case you should either save this component with a unique
name, or save your component on top of the one already existing)
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12. Move the photoresistor to the spot you want it in the circuit.

13. Now we will create the buzzer. The buzzer is a polarized device, so a good starting point is
a polarized capacitor. Go to the component selector, choose a polarized capacitor, ungroup
the capacitor, and then add a circle to the symbol to distinguish it as a buzzer. Group the
entire object as a component with part ID, “BZ1,” and label “CEP-2224" and save the
component as a “Buzzer” under custom components. At the last step, you’re display will be
as follows:
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14. Now we need to add our connections to power and ground. Let’s start with ground. Go to
the “symbol or signal label” tool, which looks like a ground, and select “Power — ground”
from the text box in the upper right.
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15. Place 5 grounds into the circuit, at the bottom of R2, near pins 1 and 4 of the LM311, near
the bottom of the capacitor, at the emitter of the BJT, and at the bottom of the potentiometer.
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16. Repeat this process, but using “Power — Voltage Supply +9V” to put 5 power connections in
at the top of R1, the photoresistor, pin 8 of the LM311, the top of R3 and the top of the

buzzer.
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17. Now let’s add in our battery connection. Place a battery into the circuit, using “Misc —
Battery.” Assign the battery the part ID “B1” and give it the label “9OV.” Then, use the
symbol tool to add a ground connection and a +9V network connection (this will link the
positive terminal of the battery with every other point in the circuit that should go to 9V—if
you wanted to add a switch to the circuit, you would add it between the + terminal of the
battery and the ‘+9V’ symbol.)
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18. Now select the wire tool, and wire your circuit together. The left-click starts the wire and
sets a bend, and the right click ends a wire. After wiring, the schematic should appear as

follows:
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19. Save your work, using “Save As..” to create a unique filename.
20. Check your file for netlist errors using “File” -> “Check schematic for netlist errors”
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21. The pins inside of the BJT are not specified (this is because pin assignments vary for
different BJTs) so you will probably will get an error message, like that shown below:
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22. Hit “cancel” on the error message, and then as that message suggested, select the part and
choose “Component” and then “Ungroup Component.” This example uses the 2n1711 BJT
in the little tin can (the TO-39 package). For this package the base is pin 2, the emitter is pin



1, and the collector is pin 3. To set this in the schematic, double click on just the collector
pin, and assign it to pin 3.
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23. In a similar fashion, assign “2” to the base, and “1” to the emitter. Then select the entire
component (this takes a lot of shift-clicking—be sure to get all the little parts), choose
“Group to make component” from the Component menu, and assign the part ID to be Q1.
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24. If you’re going to be using the transistor again, it’s probably a good idea to then click on it,
select “Component” -> “Save custom component” and save it as the transistor name, which
in this case is 2n1711.
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25. Now check your file for netlist errors again, using “File” -> “Check schematic for netlist
errors,” you mlght get an error hke that shown below (1f not sk1p to #28)
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26. The cause of this error is that the wire isn’t really connected. The “snap-to-grid” function
has prevented you from making a connection. Hit continue to exit the netlist check. Then



toggle the “snap-to-grid” function off, select the errant line end(s) and move it (them) into
the correct position. Repeat this process until all the lines are properly connected.
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27. Reattempt the netlist error check.
28. Once the netlist error check runs clean, you will be asked to save your file, which you
should definitely do. The final schematic should look like this:
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29. Print your schematic to reference as you work on your layout. At this point, you should
review your schematic carefully to check for errors. Once you are satisfied that the
schematic is correct, close ExpressSCH.



Creating the Layout in ExpressPCB

When doing the layout, it is particularly useful to have the actual components and/or in front of you,
along with a ruler or set of calipers (the ruler and calipers are unnecessary for this tutorial).

1.

L]

Open ExpressPCB. When you first open the program, a dialog box appears with links to the
Quick Start Guide and a PCB Design Tips file. If you have time, both of these links can be
instructive. Once you’re ready to continue, hit OK to go to a new file.

Under “File” select “New file.” Choose the 2-layer board, with Default via ‘0.056” round
via with 0.029” hole’. Change both default clearances for the filled planes to 0.05 (the

maximum allowed). Hit OK and again OK on the warning that appears in the next window.
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Board properties

Number of copper layers:
(¢ 2 layers - top and bottom
(" 4 layers - top and bottom plus power and ground internal planes

Default via:

0.056" round via with 0.029" hole  (hole tolerance +/-0.004) L‘

Default clearance in filled planes (outer layers only):
Default clearance around traces (inches): |0.05

Default clearance around pads (inches): |0.05

i Help setting these values... 0K

v o
Sl
QIR

X -0.275 Y:-0.425 Snap: 0.025"

The yellow hne on the screen shows the boundary for the PCB The default boundary is 3.8

x 2.5 inches, which matches the express PCB miniboard service. This demo will use the
entire board—however for our class project you should only use half the board (1.9” x
2.5”) so that we can double up designs. Also, be aware that no copper (pads or traces) can
be placed closer than 0.025" to the perimeter of the board.




3. The first thing you need to do is to place all of your components onto the layout. Let’s start
with the resistors. Select the component placing tool, which looks like a little IC, and from
the pull-down menu on the upper right choose “Resistor-0.25 watt (lead spacing 0.4 inch).”

(This description matches the small resistors in Ri-024). Put 4 resistors on the schematic.
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4. Now double click on each of the resistors to bring up the component properties box, and
assign the resistors with part IDs R1, R2, R3, and R4.
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5. The LM311 for this example is in an 8-pin DIP package, so you place the comparator using
the component “Dip 8-pin.” Notice how the square pad denotes pin 1.
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6. Double-click on the component and assign the part with the part ID “U1”
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7. Now add the following components (this assumes that each of these component descriptions
match the components in the circuit—it’s good to confirm this with a ruler when you go to
build your own circuit—matching lead spacings are particularly important):



a. A capacitor with the description “Cap — radial electrolytic — Lead spacing 0.2 inch”
and give it part ID, “C1” (notice how the square pad denotes the positive lead)
A transistor with the description “Semiconductor — TO-39” and give it part ID, “Q1”
c. A potentiometer with the description “Potentiometer — Bourns series 3386H” and
give it partID, “R5”
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8. Save your work.

9. Now we need to build the components that aren’t already in the library: the photoresistor,
and the buzzer. Let’s start with the photoresistor. The photoresistor dimensions are as
follows (you could get this either from the data sheet or by measuring the actual component
with calipers):

PACKAGE DIMENSIONS INCH [mm]

+015 (0.38]

+010 [0.25} -010 [0.25] EPOXY ON LEADS 3 mm MAX
138 13.50) 679 [2.00}
( 2X @.016 [0.40]
7L 1
1

1100 [2.54]
3

/ 7 L J —L
PLASTIC

+010[0.25 COATED
©.165 [4.19]
o 2X1.023[26.0]

CERAMIC PACKAGE

Like before, the easiest way to build a new component is to start with one that is similar. So
we look through the component options for a two-pin component with a 0.1” lead spacing. A



good choice is “Cap — lead spacing 0.1 inch.” Place this component on the diagram, and
zoom in so that you can get a better view.
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10. Now select the component and choose “Component” -> “Ungroup PCB Component” to
break the component down into parts.
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11. Remove the boundary around the part, and then draw in a circle using the arc tool. Then
double click on the circle to set its properties, and set the radius to 0.0825, and the layer to

the silkscreen layer (the yellow layer).
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13. Double click on the new component, and give it the part ID “PR1” to match the

photoresistor ID from your circuit schematic.
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14. To use this component again, save your component using “Component” -> “Save custom
component,” and save the component as “photoresistor” (if you use this in your design later,
be sure that your photoresistor matches these dimensions—if not you will need to create a

new part).
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15. Now we will repeat this process for the buzzer, which has the dimensions shown below
(given in mm):

nce: £0.5

To create this part, we will start with a capacitor base again, this time with a lead spacing of
0.6 inch (15 mm). It’s best to use a polarized capacitor, as the buzzer is polarized. Let’s use
“Capacitor — Axial electrolytic — Lead spacing 0.6 inch.” After placing this part, the display
will be as follows:
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16. Ungroup the component, delete the rectangle, and add a circle in the silkscreen layer that has
a radius of 0.5 inches. Move other components out of the way if they are too close. Your
display will then look as follows:
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17. Now we need to check that the pads are large enough for the buzzer, which has fat leads.
Double click on one of the pins to pull up its properties:
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Set properties of the selected pad
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The holes have a diameter of 0.035”, which corresponds to 0.89 mm. This could be a little

tight for our buzzer, where the pin diameter is specified as 0.8 +/- 0.1 mm. Pull down on
the “pad type” menu and select ‘0.100” square pad with 0.046” hole” which gives us a little




clearance. (You need to make the pad and hole large enough that it the part will fit
considering tolerances on pin dimension and placement, but if you make the holes too big it
will be harder to solder the part in place --- a beginner should err on the side of making the
hole too large).
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18. Repeat this process with the other pad to make it ‘0.100” round pad with 0.046” hole’
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19. Select all the parts of the buzzer, group it as a component, and give the component part ID
“BZ1” to match the schematic. Save your component as “buzzer” to use again later. (If
someone else has already completed the tutorial on this computer, the part may already
exist, in that case you should either save this component with a unique name)
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20. Finally, we need to add in the battery, which is going to be connected by a battery strap to

the circuit, and therefore requires only two pads (the battery will lie off of the board). This

is a good opportunity for us to create a part from scratch. Use the pad tool to place a pad

with the description ‘0.150” square pad with 0.079” hole’ to be the positive battery lead.
EEX
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21. Make this pad correspond to pin 1 for the battery by choosing it with the select tool, and
assigning it to be pin 1.
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22. Create another pad, this time round, using the description, ‘0.150” round pad with 0.079”
hole,” near the first pad, and assign it to be pin 2. Then select both pads, and group them to
make a component. Label the component with the Part ID “B1.” Save the part as “battery

strap connection” in the component library.
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23. Now (Finally!) we have all the components on the board. You can now link in the
schematic file. To do this, select “File” -> “Link schematic to PCB...”
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24. Select your schematic file. You should then get a message like this:
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25. Now if you select the net tool, and click on a pin, Express PCB will highlight all of the pins
that should connect to that pin. For example, select the net tool and click on the + terminal
of the battery, you should see something like this:
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Click on some of the other pins to check your work and to get a sense of how the parts will

connect.

26. Now, we want to arrange our components in a logical fashion. Your goal is to minimize the
length of connecting wires. You also would like (ideally) to have a single ground plane on
the back and all of other connections on the front surface, which means that you want to
avoid having to cross wires over one another (this can’t always be avoided). To rotate a
component, right click on it and select the desired rotation. For example, here it might be
nice to rotate R4:
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27. Rotate the transistor and arrange the other parts until your board looks like this:
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28. Now its time to draw in connection lines. One thing that you must consider when drawing
connector lines is the current capacity of the lines on the board. Here are some general rules
of thumb on line widths from the ExpressPCB web site:

0.010" 0.3 Amps
0.015" 0.4 Amps
0.020" 0.7 Amps
0.025" 1.0 Amps
0.050" 2.0 Amps
0.100" 4.0 Amps
0.150" 6.0 Amps

Most of our circuits will not draw more than 100 mA, so any line width should be
acceptable. However, if your circuit uses a component that draws a significant current, such
as a motor, than you should err towards larger line widths.

Let’s begin with the +9V lines. Use the net tool to highlight the +9V net on your board.
Then click on the wire tool and select the upper metal (red) layer, and a 0.1 trace width
(this is overkill, but it’s a good habit to make the power lines fat). Connect the + terminal of
the battery to the top of the buzzer:



*#**Error: Please pick this button for Green so tracks are on bottom.
—JW & KD

=7~ ExpressPCB - C:\Documents and Settings\Firebaugh-Crave

File Edit View Component Layout Help

e

2| »| &

& |®| 515 = k| [0700 000 ] wla s [

&7

r
'
L2}

*

N ]

il R ded

Yo
X:3825  Y:2200 Snap: 0.025" -
P —
g start r & Prototyping Lab ’ &l EXPRESS PCB TUTOR... ExpressPCE - C

29. Now connect to the other +9V points in the circuit.
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30. The potentiometer (RS5) is a little close to the one power connection, so rotate it and shift it
over:
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31. Now create the signal connections. Highlight the unconnected pin of the photoresistor with
the net tool, then select the wiring tool and a 0.025” line width, and connect the
photoresistor to the potentiometer as shown:
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32. Complete the connections and repeat this process for the other signal nodes in the circuit.
When you get to R4, you may notice that the component would be more easy to wire if it
were flipped, you can right-click on the component to accomplish this:
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33. After all the signal lines are completed, your circuit should look as follows (only the
grounds are unconnected):
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34. Now for the ground plane. Select the “Place a filled plane” tool, which is the green tool
right above the circle tool. Say OK to the informational message on the tool that pops up,
and then create a box that encompasses the entire circuit on the bottom layer of the chip—
but leaving a boundary of at least 0.025” from the board edge. To do this, choose the
green layer from the top bar, then click near the upper left corner of the board (at least
0.025” from both boundaries). Click again near the upper right corner...at this point your
display looks something like this:
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35. Continue down to the bottom right corner and then to the bottom left corner. Then right-
click to end the box. Your display should now look like this:
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Notice how there is a space around each pad in the layer. The width of that space is
controlled by Board Properties, under the “Layout” menu, and we set that at the largest
possible size when we started this process (in step 2).

36. Now we need to make our ground connections. Use the network tool to highlight the ground
connections. Right-click on the ground pad for the battery. Select “Bottom layer pad
shape” and then “Thermal pad to filled plane.” This will link that pad to the ground plane.
The thermal pad has some thermal isolation between it and the rest of the plane, which will
make it easier to solder later.
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37. Repeat this for all of the ground pads in your layout. Your layout should now look like this:
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38. For your own circuit, you should also add your initials in an unused corner of the chip. Do
these initials in the top metal (red) layer rather than in the silkscreen (yellow) layer, because
if we use mini-boards, the silkscreen layer is not included. To add text, select the text tool,
select the layer where you want the text to appear, and enter the text in the box on the upper
right. Then click on the layout to place the text:
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39. Carefully inspect your circuit board. Use the layer visibility tools in the bottom left corner
to turn off and on layers. Zoom in to check for connections. Highlight all of the pads with
the network tool on to verify that they are correctly connected. Print out your circuit and
confirm that every connection specified in the schematic is present. With circuit boards, you
definitely want to measure twice and cut once. At this point, you would be ready to submit
the circuit.



